Multiple issues in 9.1

Bugs, errors in the program.
Post Reply
donzi2k
Posts: 7
Joined: Mon Oct 21, 2013 3:37 pm

Multiple issues in 9.1

Post by donzi2k »

Hi there. Long time user, but have not been able to reach out to anyone through main website. Here are some issues I'm experiencing:

Downloader.exe will not download from https
Uninstaller displays app name as %s
System-Commands->after/before install/uninstall don't fire off

I have some more but these are a start. please advise.

thanks
donzi2k
Posts: 7
Joined: Mon Oct 21, 2013 3:37 pm

Re: Multiple issues in 9.1

Post by donzi2k »

Couple more to add:

Close main executable & Close running application (with filename) don't close application
When setup launches, and detects a new version, it downloads and runs the new setup, but doesn't close the original.

-donzi2k
Leo
Site Admin
Posts: 419
Joined: Fri Jan 22, 2010 12:40 pm
Contact:

Re: Multiple issues in 9.1

Post by Leo »

Downloader supports secure urls (https). Please send your url at our email.
Regarding Uninstaller displays app name as %s, it seems you use old language file in the latest v9.1. There were changes in language file. Please use original file.
What commands are you trying to execute?
Close main executable & Close running application just inform user to close it.
You can add commands to automatically close exe files (System /Commands):
https://www.actualinstaller.com/help/commands.html

Code: Select all

/C taskkill /F /IM notepad.exe /T
Leo,
Actual Installer Team
http://www.actualinstaller.com
donzi2k
Posts: 7
Joined: Mon Oct 21, 2013 3:37 pm

Re: Multiple issues in 9.1

Post by donzi2k »

Hi,

I've sent emails from my work and personal without a response.

the url i'm attempting to use is:
https://auth.posabilities.com/update/update.txt
You are ignoring the S part of http.

I had thought I created the installer package from scratch and not updated but will try again.

Here are the commands attempting to be executed. It looks like it's trying, but I can't grab the output window. I've tried various combinations of these settings.
Image

I'll try running the kill process via command, but why have the option in the installer?

Thanks,

donzi2k
donzi2k
Posts: 7
Joined: Mon Oct 21, 2013 3:37 pm

Re: Multiple issues in 9.1

Post by donzi2k »

Hi Leo,

Creating an install package from scratch still produces the %s for the uninstaller.
donzi2k
Posts: 7
Joined: Mon Oct 21, 2013 3:37 pm

Re: Multiple issues in 9.1

Post by donzi2k »

Hi,

Was able to resolve my ngen command issue by wrapping changing to "<MainExecutable>"

When does "Start Installation" trigger? I couldn't find a definition in help.

-regards,

donzi2k
Leo
Site Admin
Posts: 419
Joined: Fri Jan 22, 2010 12:40 pm
Contact:

Re: Multiple issues in 9.1

Post by Leo »

New version of Downloader 3.3 works correctly with secure connection. A download link is sent to your email.
There is no timing in commands "Strat Installation". There is "Start Uninstallation", it triggers when uninstaller is started, before asking a user to uninstall the app. "Before Uninstallation" triggers after the user clicks Yes.
Regarding the title on Uninstaller: please open language file (e.g. for English: "C:\Program Files (x86)\Actual Installer\Languages\English.lng"), find this setting, make sure it is correct:

Code: Select all

[Uninstall]
0=Uninstall %s
Leo,
Actual Installer Team
http://www.actualinstaller.com
donzi2k
Posts: 7
Joined: Mon Oct 21, 2013 3:37 pm

Re: Multiple issues in 9.1

Post by donzi2k »

Hi Leo,

I've downloaded the updated downloader and will let you know if i have any issues. I had made an interim Downloader.exe but feel like I was missing something, hopefully with yours the flow will be less clunky.

thank you for clarifying the start uninstall

i did verify in the language file and appears to be correct.
Image

thanks again
Leo
Site Admin
Posts: 419
Joined: Fri Jan 22, 2010 12:40 pm
Contact:

Re: Multiple issues in 9.1

Post by Leo »

There was a bug in v9.1: when using the option "Overwrite" in the "If Previous Version is Installed", the file Uninstaller is not updated.
Old uninstaller shows in the title "%s".
This bag is fixed in new version 9.2:
https://www.actualinstaller.com/news/release-9.2.html
Leo,
Actual Installer Team
http://www.actualinstaller.com
Post Reply