Can't change app install directory or program files folder

Bugs, errors in the program.

Can't change app install directory or program files folder

Postby fof9l » Wed Sep 25, 2013 9:10 pm

When running the installation file for my app, I can't change the path for the installation of the resulting app or the Windows folder it goes into. The selection boxes are greyed out, and so is the "Browse" button on the file install window. I'm sure I'm doing something wrong, but I'm darned if I can find what it is, so I'm reporting it as a bug. Maybe it's a bug with the program, or maybe it's a bug with the user...
fof9l
 
Posts: 6
Joined: Mon Mar 11, 2013 8:39 pm

Re: Can't change app install directory or program files fold

Postby Leo » Fri Sep 27, 2013 2:22 am

It is not a bug.
Your installation works as an Update, so it uses the destination folder from the initial installation.

To turn it to the new installation go to the Installation \ Upgrade tab and select "Uninstall old installation".
Leo,
Actual Installer Team
http://www.actualinstaller.com
Leo
Site Admin
 
Posts: 361
Joined: Fri Jan 22, 2010 12:40 pm

Re: Can't change app install directory or program files fold

Postby fof9l » Sun Sep 29, 2013 6:03 am

Thanks for this, Leo; I knew there had to be an answer somewhere.

However, I don't want to uninstall the previous version, or at least, not all of it; there are some files that I need to leave in place in the user's directory, and with this update, I'm replacing only those files that need updating. It's not necessary to replace all the files, and in fact if I do, the user's settings in their .ini file would be lost. So I tried the setting to "allow multiple versions of the program", and that seemed to work fine, in terms of only replacing the files that were obsolete, and leaving the rest untouched. Was this the right thing to do? It seems to have worked...

Thanks,

Nigel
fof9l
 
Posts: 6
Joined: Mon Mar 11, 2013 8:39 pm

Re: Can't change app install directory or program files fold

Postby Leo » Thu Oct 03, 2013 1:17 pm

Then the first method was correct.
Leo,
Actual Installer Team
http://www.actualinstaller.com
Leo
Site Admin
 
Posts: 361
Joined: Fri Jan 22, 2010 12:40 pm


Return to Bug Reports

Who is online

Users browsing this forum: No registered users and 1 guest

cron