.Net Framework 4.0 Error

Common questions about using Actual Installer.
Post Reply
Posts: 5
Joined: Wed May 08, 2013 9:25 pm

.Net Framework 4.0 Error

Post by Pizzor2000 »

A few weeks ago, I installed Visual Studio 2015 and .Net Framework 4.6 on my development computer. It seems like since then, I cannot run AI setup programs I created requiring .Net 4.0 Client. I get the following message when I start the setup:
This installation requires .NET Framework 4.0 Client or higher to be installed on the computer.
Installation cannot continue.

Would you like to install it now?
I tried reinstalling Microsoft .Net Framework 4, but I get the following message:
Same or higher version of .NET Framework 4 has already been installed on this computer.
The setup program I am trying to run was created with Actual Installer 5.0. In the Software Prerequisites tab, I checked Minimum Software Version for .NET Framework, and selected 4.0 Client.

I created this setup over a year ago, and I have run it a few times on this system, as recently as a few months ago, with no problem. As I mentioned earlier, it seemed to stop working when I upgraded to the latest framework.

My workaround has been to turn off the .Net Framework prerequisite on my setup project and rebuild--the installer would run if I did this, but I don't think this is an ideal solution.
Post Reply