v6.2 does not check registry

Bugs, errors in the program.
Post Reply
Posts: 2
Joined: Fri Apr 03, 2015 10:32 pm

v6.2 does not check registry

Post by hefy_jefy »

I just upgraded from v4.8 to v6.2.
One of my projects needs to check for the existence of a specific VS 2008 C++ redistributable on the target PC. In the previous version of Actual Installer this worked perfectly and if the registry key did not exist then the redistributable was run from a temporary folder. This does not work now, v6.2 does not seem to check the registry - I have tried re-entering the Registry Key settings. Attached is a screenshot of the prerequisites tab settings.

http://www.tritonimaginginc.com/site/co ... eyCond.jpg

Posts: 25
Joined: Mon Nov 30, 2015 5:50 pm

Re: v6.2 does not check registry

Post by ggrewe »

If you are doing this check in Prerequisites, be sure you have the Registry bitness set appropriately. If you are using "Any" on a 64 bit system, it may not be checking HKLM\SOFTWARE\WOW6432Node\...

We are using v6.2 and check for the VS runtimes with every installation without issue.
Post Reply